debian lennyでapt-getできないの巻

どうしてもlinuxでunzipが使いたくて久しぶりにapt-getしたら...なんかエラーでます!

いろいろ調べた結果...lennyの次のバージョンがリリースされていたせいでした!
あああああ
sources.listで常にstableを使う設定にしていたのが原因でした。

cat /etc/apt/sources.list

#deb file:///cdrom/ sarge main

#deb http://ftp.debian.org/debian/ stable main ←間違い
deb http://ftp.debian.org/debian/ lenny main
#deb-src http://ftp.debian.org/debian/ stable main ←間違い
deb-src http://ftp.debian.org/debian/ lenny main
#deb http://security.debian.org/ stable/updates main ←間違い
deb http://security.debian.org/ lenny/updates main