drupal4.5.1インストールの試行錯誤記録

はじめに前提環境
・x86版のVine3.1
Vine3.1なら最低apache2とphp4はインストールされているはず。
drupalの動作にはプラスデータベースが必要。
どうやらMySqlがよいようなのでインストールした。

しかし問題が発生!drupalはphp5未対応(DB接続部分がライセンスの関係でphp5から配布されなくなったことが原因らしい。)
うちのシステムはapt-upgradeしてあって、php5になっている。
そこでphp4へダウングレードも実施した。
(phpのバージョンが4ならばダウングレード工程をはぶけばOKのはず。)